Các bước chuẩn cho cấu hình router Đơn vị

Go down

Các bước chuẩn cho cấu hình router Đơn vị

Post  telecom1988 on Tue May 12, 2009 1:55 pm

Các bước chuẩn cho cấu hình router Đơn vị.

--------------------------o0o------------------------------


1. Vào mức cấu hình

Router>en
Router# conf t
Router(config)#

2. Cấu hình tên của router

Router(config)# hostname <tên router>

3. Cấu hình password enable

Router(config)# enable secret <password enable>

4. Cấu hình authentication
Nhận thực qua các accout local: thực hiện cho việc nhận thực cho quyền truy xuất vào router hoăc nhận thực cho quay số (có thể không dùng AAA server)

Router(config)# username <tên_đăng_nhâp> password <password>

Nhận thực qua AAA server (Optional, nếu có AAA server được cài đặt)

Router(config)# aaa new-model
Router(config)# aaa authentication login default group tacacs local // các user trên
AAA sử dụng tacacs (cũng có thể là radius)
Router(config)# tacacs-server host <địa chỉ của AAAserver>
Router(config)# tacacs-server key <key_đặt đồng bộ với AAAserver>

Option:
Router(config)# aaa authentication login telnet tacacs local
// telnet: tên group định nghĩa các accout được quyền truy xuất vào router (có thể áp vào các line), thường sử dụng đối với line vty để quản lý các accout telnet tới router bằng AAA server

5. Cấu hình cho phép routing bằng phần cứng (Optional: đối với những dòng router có hỗ trợ, từ 2600, thực hiện routing nhanh hơn bằng cache)

Router(config)# ip cef
Router(config)# ip subnet-zero


6. Cấu hình cho phép telnet và console cùng các chính sách thực hiện bảo mật cho telnet và console
Với line vty (telnet):
Router(config)# line vty 0 4
Router(config-line)# password <password_telnet>
Router(config-line)# login

Option:
Router(config-line)# login authentication telnet // sử dụng authen cho các phiên
telnet bằng AAA server
Với line console:
Router(config)# line console 0
Router(config-line)# password <password_console>
Router(config-line)# login

7. Cấu hình cho các interface
Interface kết nối WAN lên Tcty

Router(config)# interface Serial x/y
Router(config-if)# description Connected to WAN EVN - 2048Mbps
Router(config-if)# bandwidth 2048 // Option, phục vụ cho statistic
Router(config-if)# ip address <Địa chỉ IP> <subnet_mask>
Router(config-if)# no shut
Router(config-if)# encapsulation ppp // Option, nếu đầu WAN cũng thực
hiện encap ppp

Interface kết nối tới LAN của đơn vị
Router(config-if)# interface Ethernet t/v
Router(config-if)# ip address <Địa_chỉ_IP> <Subnet_mask>
Router(config-if)# half-duplex // nếu nối tới 1 cổng fastethernet thường đặt full-
duplex hoặc để ở chế độ auto
Router(config-if)# no shut

8. Cấu hình routing cho đơn vị lên Tcty
Tạo một route tĩnh trỏ lên Tcty

Router(config)# ip route 10.0.0.0 255.0.0.0 <Next_hop> // Next-hop là địa chỉ IP
của phía Tcty sử dụng trong kết nối point-to-point, có thể
thay trực tiếp bằng: se x/y

9. Cấu hình quay số. (Optional)
Đặt các câu lệnh chat-script để khởi tạo cuộc gọi.

Router(config)# chat-script reseting "" "atz" OK "ats0=1"
Router(config)# chat-script dialing "" "atdp\T" TIMEOUT 30 CONNECT \c

Cấu hình mức logical

Router(config)# interface Group-Async1
Router(config-if)# ip unnumbered Ethernet0/0 // sử dụng ip add của ethernet 0/0,
hoặc có thể đặt một IP cho cổng async trung với dải địa chỉ cấp cho các đơn vị
Router(config-if)# ip directed-broadcast
Router(config-if)# encapsulation ppp
Router(config-if)# ip tcp header-compression
Router(config-if)# no ip mroute-cache
Router(config-if)# async mode dedicated
Router(config-if)# peer default ip address dhcp // cấp địa chỉ cho các user đơn vị
quay số vào, có thể thay dhcp
bằng một pool được định nghĩa
Router(config-if)# keepalive 300
Router(config-if)# pulse-time 3
Router(config-if)# ppp authentication pap
Router(config-if)# group-range z // line tương ứng có modem kết nối tới, có thể
cấu hình cùng lúc cho nhiều line VD line 33 - 44



Cấu hình mức physical
Có 2 khả năng có thẻ xảy ra, modem cắm vào line async hoặc cắm vào int se đặt ở chế đồ async, tuy nhiên cấu hình cho cả 2 trường hợp đều không có nhiều khác biệt

Với line quay số:
Router(config)# line z // line tương ứng có modem kết nối tới, có thể cấu hình
cùng lúc cho nhiều line VD line 33 - 44
Router(config-line)# script reset reseting
Router(config-line)# script dailing
Router(config-line)# modem InOut // Dialin thay cho InOut nếu modem
chỉ nhận cuộc gọi
Router(config-line)# modem autoconfigure discovery
Router(config-line)# transport input all
Router(config-line)# flowcontrol hardware
Router(config-line)# stopbits 1
Router(config-line)# speed 115200

Với interface serial hoạt động ở chế độ async:
Router(config)# int se x/y
Router(config-if)# physical-layer async // đặt interface hoạt động ở chế độ async
<Các câu lệnh còn lại tương tự cấu hình cho line >



10. Cấu hình QoS phục vụ hội nghị truyền hình (Optional)

Router(config)# access-list 10 permit <địa_chỉ_của_enpoint>
Router(config)# class-map match-all DSCP34
Router(config-cmap)# match ip dscp af41
Router(config-cmap)# exit
Router(config)# class-map match-all VCS-Traffic
Router(config-cmap)# match access-group 10 // Nếu đã có access-list 10 ta có
thể sử dụng chỉ số khác (nhỏ hơn 100)
Router(config-cmap)# exit
Router(config)# policy-map DonViQOS
Router(config-pmap)# class DSCP34
Router(config-pmap-c)# bandwidth 1536
Router(config-pmap)# exit
Router(config)#exit
Router(config)# policy-map MarkEVNVCS
Router(config-pmap)# class VCS-Traffic
Router(config-pmap-c)# set ip dscp af41
Router(config-pmap-c)#exit
Router(config-pmap)# class class-default
Router(config-pmap-c)# set ip dscp af42
Router(config-pmap-c)# exit
Router(config-pmap)#exit
Router(config)#

Sau khi tạo policy ta cần thực hiện các policy vào các cổng để thực hiện priority cho các gói tin của end-point:

Router(config)# int se x/y // interface thực hiện kết nối WAN
giữa đơn vị và Tcty
Router(config-if)# service-policy output DonViQOS

Router(config-if)# int ethernet t/v // interface nối tới đơn vị có kết nối tới end-
point (thường là int nối tới LAN đơn vị)

Router(config-if)# service-policy input MarkEVNVCS
Router(config-if)# exit
Router(config)#

11. Cấu hình SNMP phục vụ cho nhu cầu quản trị

Router(config)# snmp-server community <string_đinh_nghĩa> RO
Router(config)# snmp-server community <string_đinh_nghĩa> RW
Router(config)# snmp-server host <Địa chỉ IP của máy monitor> //(option)
Router(config)# logging <Địa chỉ của máy thực hiện monitor> //(option)
12. Kết thúc cấu hình
Lưu cấu hình vào NVRAM

Router# write memory

Xem cấu hình

Router# show run

Kiểm tra cấu hình

Router# ping 10.0.8.99

Thực hiện từ PC ping vào router đơn vị. router backbone, telnet


-----------------end--------------------
avatar
telecom1988
Admin

Posts : 317
Join date : 2009-04-08
Age : 30
Location : 144 Xuan Thuy - Cau Giay - Ha Noi

View user profile http://banks.forum.st

Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum