Các bước chuẩn cho cấu hình Switch Đơn vị

Go down

Các bước chuẩn cho cấu hình Switch Đơn vị

Post  telecom1988 on Tue May 12, 2009 1:56 pm

Các bước chuẩn cho cấu hình Switch Đơn vị.

--------------------------o0o------------------------------


1. Vào mức cấu hình

Switch>en
Switch# conf t
Switch(config)#

2. Cấu hình tên của Switch

Switch(config)# hostname <tên Switch>

3. Cấu hình password enable

Switch(config)# enable secret <password enable>

4. Cấu hình authentication
Nhận thực qua các accout local: thực hiện cho việc nhận thực cho quyền truy xuất vào Switch hoăc nhận thực cho quay số (có thể không dùng AAA server)

Switch(config)# username <tên_đăng_nhâp> password <password>

Nhận thực qua AAA server (Optional, nếu có AAA server được cài đặt)

Switch(config)# aaa new-model
Switch(config)# aaa authentication login default group tacacs local // các user trên
AAA sử dụng tacacs (cũng có thể là radius)
Switch(config)# tacacs-server host <địa chỉ của AAAserver>
Switch(config)# tacacs-server key <key_đặt đồng bộ với AAAserver>

Option:
Switch(config)# aaa authentication login telnet tacacs local
// telnet: tên group định nghĩa các accout được quyền truy xuất vào Switch (có thể áp vào các line), thường sử dụng đối với line vty để quản lý các accout telnet tới Switch bằng AAA server

5. Cấu hình cho phép telnet và console cùng các chính sách thực hiện bảo mật cho telnet và console
Với line vty (telnet):

Switch(config)# line vty 0 4
Switch(config-line)# password <password_telnet>
Switch(config-line)# login

Option:
Switch(config-line)# login authentication telnet // sử dụng authen cho các phiên
telnet bằng AAA server
Với line console:
Switch(config)# line console 0
Switch(config-line)# password <password_console>
Switch(config-line)# login

6. Cấu hình VLAN cho switch (Optional)

Tạo VLAN

Switch# vlan database
Switch(vlan)# vlan x name ABC //x: chỉ số VLAN, nên khác 1, vlan 1 = vlan mặc
định, ABC: tên VLAN, mang tính biểu tả
Switch(vlan)# exit

Cấu hình cho interface thuộc về VLAN

Switch(config)# interface ethernet y/z
Switch(config-if)# description VLAN x, ABC
Switch(config-if)# switch-port mode access
Switch(config-if)# switch-port access vlan x

7. Cấu hình interface hoạt động ở trunk interface
Thực hiện kết nối Switch-Switch, Switch-Router, truyền các gói tin của các VLAN

Switch(config)# interface ethernet y/z
Switch(config-if)# description trunk VLANs
Switch(config-if)# switch-port mode trunk

8. Cấu hình routing cho VLANs (Optional)
Thực hiện trên interface của router or switch layer 3 neighbors
Router (Cisco Recommand: Đối với cấu hình trunk cho router thực hiện chức năng cho routing cho các VLAN nên sử dụng đường fa với dòng router Cisco lớn hơn 2600 serial)

Sử dụng mỗi subinterface tương ứng cho một VLAN:

Router(config)# interface Fa x/y.z
Router(config-subif)# description Noi toi VLAN z
Router(config-subif)# encapsulation dot1q.z // chỉ số z ở đây rất quan trọng, nó chỉ ra tương ứng với VLAN z. VD: VLAN 3  encapsulation dot1q.3
Router(config-subif)# ip add <IP_net_ABC> <Subnet> // Trong các trường hợp sử dụng Router để routing giữa các VLAN, không cần thiết đặt IP cho các VLAN trên Switch làm default gateway, thay vào đó sử dụng IP của subinterface làm default gateway cho mạng của VLAN đó

Sau khi đã chỉ ra các VLAN tương ứng với các subinterface, thực hiện routing cho các subnet thuộc về các VLAN như bình thường (sử dụng các giao thức định tuyến)

Switch Layer 3
Cấu hình tương tự như đối với router.
Riêng đối với việc routing cho các VLAN trên local switch có thể thực hiện bằng câu lệnh:

SwitchL3(config)# ip routing

9. Cấu hình địa chỉ IP cho các VLAN
Trong một số trường hợp địa chỉ của VLAN trong trường hợp này được sử dụng làm defaut gateway cho mỗi subnet thuộc về VLAN (Optional)

Switch(config)# interface vlan x
Switch(config-if)# description net ABC
Switch(config-if)# ip address <IP_default_gateway> <Subnet_mask>
Switch(config-if)# no shut

Cấu hình này thường sử dụng để định nghĩa một địa chỉ IP sử dụng cho việc telnet để quản lý Switch từ xa bằng cách đặt một IP cho VLAN 1 (interface vlan là một cổng ảo)

Switch(config)# interface vlan 1
Switch(config-if)# description telnet
Switch(config-if)# ip address <IP_telnet> <Subnet_mask>
Switch(config-if)# no shut

10. Cấu hình SNMP phục vụ cho nhu cầu quản trị

Switch(config)# snmp-server community <string_đinh_nghĩa> RO
Switch(config)# snmp-server community <string_đinh_nghĩa> RW
Switch(config)# snmp-server host <Địa chỉ IP của máy monitor> //(option)
Switch(config)# logging <Địa chỉ của máy thực hiện monitor> //(option)

11. Kết thúc cấu hình
Lưu cấu hình vào NVRAM

Switch# write memory

Xem cấu hình

Switch# show run

Kiểm tra cấu hình

Switch# ping 10.0.8.99

Thực hiện từ PC ping, telnet vào Switch
-----------------end--------------------
avatar
telecom1988
Admin

Posts : 317
Join date : 2009-04-08
Age : 30
Location : 144 Xuan Thuy - Cau Giay - Ha Noi

View user profile http://banks.forum.st

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum