Electronic-Telecommunication. Together Discoverly New Technology
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Frame Relay

Go down

Frame Relay Empty Frame Relay

Post  telecom1988 Fri Jul 31, 2009 1:01 am

// Configure Frame-Relay Switch
enable
conf t
host FRS
frame-relay switching
int serial 1
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay intf-type dce
frame-relay route 122 int serial 2 221
frame-relay route 123 int serial 3 321
clock rate 64000
no shutdown
exit
inter serial 2
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay intf-type dce
clock rate 64000
no shutdown
frame-relay route 221 inter serial 1 122
exit
inter serial 3
encapsulation frame-relay
frame-relay lmi-type ansi
frame-relay intf-type dce
clock rate 64000
no shutdown
frame-relay route 321 inter serial 1 123
exit


//Configure R1
enable
conf t
hostname R1
int s 0
ip add 192.1.1.1 255.255.255.0
no sh
encapsulation frame-relay
exit


//Configure R2
enable
conf t
hostname R1
int s 0
ip add 192.1.1.2 255.255.255.0
no sh
encapsulation frame-relay
exit

//Configure R3
enable
conf t
hostname R3
int s 0
ip add 192.1.1.3 255.255.255.0
no sh
encapsulation frame-relay
exit

- Dung lenh show frame-relay map tren R1 ta kiem tra qua trinh dynamic map cua trong mang frame-relay
R1#show frame-relay map
Serial0 (up): ip 192.1.1.2 dlci 122(0x7A,0x1CA0), dynamic,
broadcast,, status defined, active
Serial0 (up): ip 192.1.1.3 dlci 123(0x7B,0x1CB0), dynamic,
broadcast,, status defined, active

- Dung lenh show frame-relay map tren R2 ta kiem tra qua trinh dynamic map cua trong mang frame-relay
R2#show frame-relay map
Serial0 (up): ip 192.1.1.1 dlci 221(0xDD,0x34D0), dynamic,
broadcast,, status defined, active
- Dung lenh show frame-relay map tren R1 ta kiem tra qua trinh dynamic map cua trong mang frame-relay
R3#show frame-relay map
Serial0 (up): ip 192.1.1.1 dlci 321(0x141,0x5010), dynamic,
broadcast,, status defined, active

Nhan xet:
- Ta thay rang tu R1 co the ket noi den R2 va R3
- Nhung R2 va R3 khong ket noi duoc voi nhau
- Vay de khac phuc tinh huong nay thi ta can tao ra frame relay static map tren R2 va R3

R2(config-if)#frame-relay map ip 192.1.1.3 221 broadcast
R2#show frame-relay map
Serial0 (up): ip 192.1.1.1 dlci 221(0xDD,0x34D0), dynamic,
broadcast,, status defined, active
Serial0 (up): ip 192.1.1.3 dlci 221(0xDD,0x34D0), static,
broadcast,
CISCO, status defined, active

R3(config-if)#frame-relay map ip 192.1.1.2 321 broadcast
R3#show frame-relay map
Serial0 (up): ip 192.1.1.1 dlci 321(0x141,0x5010), dynamic,
broadcast,, status defined, active
Serial0 (up): ip 192.1.1.2 dlci 321(0x141,0x5010), static,
broadcast,
CISCO, status defined, active

********Thuc Hien Dinh Tuyen trong mo hinh mang nay******************
- Ta tao them interface loopback tren R1, R2, R3 va dinh tuyen bang eigrp
R1(config)#interface lo 0
R1(config-if)#ip add 10.0.0.1 255.255.255.0
R1(config)#exit
R1(config)#router eigrp 10
R1(config)#network 192.1.1.0
R1(config)#network 10.0.0.0

R2(config)#interface lo 0
R2(config-if)#ip add 20.0.0.1 255.255.255.0
R2(config)#exit
R2(config)#router eigrp 10
R2(config)#network 192.1.1.0
R2(config)#network 20.0.0.0

R3(config)#interface lo 0
R3(config-if)#ip add 30.0.0.1 255.255.255.0
R3(config)#exit
R3(config)#router eigrp 10
R3(config)#network 192.1.1.0
R3(config)#network 30.0.0.0

- Dung lenh show ip route kiem tra tren moi Router

R1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

D 20.0.0.0/8 [90/2297856] via 192.1.1.2, 00:00:03, Serial0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 10.0.0.0/8 is a summary, 00:12:33, Null0
C 10.0.0.0/24 is directly connected, Loopback0
C 192.1.1.0/24 is directly connected, Serial0
D 30.0.0.0/8 [90/2297856] via 192.1.1.3, 00:11:37, Serial0

R2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 20.0.0.0/8 is a summary, 00:12:19, Null0
C 20.0.0.0/24 is directly connected, Loopback0
D 10.0.0.0/8 [90/2297856] via 192.1.1.1, 00:00:18, Serial0
C 192.1.1.0/24 is directly connected, Serial0

R3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

D 10.0.0.0/8 [90/2297856] via 192.1.1.1, 00:12:01, Serial0
C 192.1.1.0/24 is directly connected, Serial0
30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 30.0.0.0/8 is a summary, 00:12:11, Null0
C 30.0.0.0/24 is directly connected, Loopback0

Nhan xet: Ta thay tu Router 1 ta thay duoc hai network 20.0.0.0 va 30.0.0.0
Tu Router 2 ta thay duoc network 10.0.0.0 cua Router 1
Tu Router 3 ta thay duoc net 10.0.0.0 cua Router 2
Tinh trang nay xay ra la do co che split horizon. No khong cho phep ta quang cao thong tin dinh tuyen ra tren cung cong giao tiep ma router do nhan duoc.

- De khac phuc tinh trang nay thi ta can phai vo hieu hoa tinh nang split horizon tren interface serial 0 cua Router 1. Bang lenh no ip split horizon eigrp 10

R1(config-if)#no ip split-horizon eigrp 10

- Ta kiem tra lai thong tin dinh tuyen tren R2 va R3
R2#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 20.0.0.0/8 is a summary, 00:02:46, Null0
C 20.0.0.0/24 is directly connected, Loopback0
D 10.0.0.0/8 [90/2297856] via 192.1.1.1, 00:02:46, Serial0
C 192.1.1.0/24 is directly connected, Serial0
D 30.0.0.0/8 [90/2809856] via 192.1.1.1, 00:01:55, Serial0

R3#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

D 20.0.0.0/8 [90/2809856] via 192.1.1.1, 00:04:15, Serial0
D 10.0.0.0/8 [90/2297856] via 192.1.1.1, 00:04:15, Serial0
C 192.1.1.0/24 is directly connected, Serial0
30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D 30.0.0.0/8 is a summary, 00:04:15, Null0
C 30.0.0.0/24 is directly connected, Loopback0
telecom1988
telecom1988
Admin

Posts : 317
Join date : 2009-04-08
Age : 36
Location : 144 Xuan Thuy - Cau Giay - Ha Noi

https://banks.forum.st

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum