Cấu hình OSPF và EIGRP

Go down

Cấu hình OSPF và EIGRP

Post  telecom1988 on Tue May 12, 2009 9:02 pm



HN(s2/0)----(s2/0)SG(s3/0)----(s3/0)DL

HN: F0/0 10.0.0.0/8, S2/0 20.0.0.0/30 (EIGRP)

SG: F0/0 30.0.0.0/8, S2/0 20.0.0.0/30 (EIGRP)

F1/0 40.0.0.0/8, S3/0 50.0.0.0/30 (OSPF)

DL: F0/0 60.0.0.0/8, S2/0 50.0.0.0/30 (OSPF)


HN:

(config)#router eigrp 100

(config-router)#net 10.0.0.0 0.255.255.255

(config-router)#net 20.0.0.0 0.0.0.3

SG:

(config)#router eigrp 100

(config-router)#net 20.0.0.0 0.0.0.3

(config-router)#net 30.0.0.0 0.255.255.255

(config-router)#redistribute ospf 10 metric 10000 200 255 255 255 1500


Metric: Bandwidth, delay, reability, load, MTU


(config)#router ospf 10

(config-router)#net 40.0.0.0 0.255.255.255 area 0

(config-router)#net 50.0.0.0 0.0.0.3 area 0

(config-router)#redistribute eigrp 100 subnets

DL:

(config)#router ospf 10

(config-router)#net 60.0.0.0 0.255.255.255 area 0

(config-router)#net 50.0.0.0 0.0.0.3 area 0
avatar
telecom1988
Admin

Posts : 317
Join date : 2009-04-08
Age : 30
Location : 144 Xuan Thuy - Cau Giay - Ha Noi

View user profile http://banks.forum.st

Back to top Go down

Re: Cấu hình OSPF và EIGRP

Post  telecom1988 on Thu May 14, 2009 1:01 pm

Note: Tất cả những router có cùng area phải cấu hình giống nhau tất cả các thông số thì khu vực đó mới hoạt động đúng chức năng được.

1. Cấu hình cơ bản

Router(config)#router ospf process ID
Router(config-router)#network Network_number Wildcard_mask area_ID

2. Cấu hình priority ở các interface để bầu DR và BDR

Priority càng lớn thì khả năng được bầu làm DR càng cao, ngược với bầu Root brige của Switch, càng nhỏ thì lại càng được bầu.

Router(config)#interface fastethernet 0/0
Router(config-int)#ip ospf priority 55

Sau khi cấu hình xong priority có thể kiểm tra bằng lệnh.

Router# show ip ospf interface f0/0

3. Chỉnh sửa lại OSPF cost metric trong mỗi interface

Cost càng nhỏ thì tuyến đó càng được coi là best path

Router(config-int)#ip ospf cost 1

4.Cấu hình OSPF Authentication ở các interface và áp dùng vào router

Authentication key được hiểu như là password để các router trong cùng một vùng chia sẻ với nhau.

a.Cấu hình authentication đơn giản

Router(config-if)#ip ospf authentication-key password
Router(config-router)#area area number authentication

b.Cấu hình authentication theo dạng mã hoá, bảo mật cao.

Router(config-if)ip ospf message-digest-key key ID md5 encryption-type key
Router(config-router)#area area ID authentication message-digest

5.Cấu hình OSPF timer trong các interface

Router(config-if)ip ospf hello-interval timer
Router(config-if)ip ospf dead-interval timer

6.Cấu hình quảng bá một tuyến mặc định trong OSPF

Router(config-router)#default-information originate

7.Quảng bà một tuyến khác (không phải là default)

Router(config-router)#redistribute protocols subnets

8.Các lệnh show dùng để kiểm tra cấu hình OSPF

show ip protocol
show ip route
show ip ospf
show ip ospf interface
show ip ospf database
show ip ospf neighbor detail
clear ip route *
debug ip ospf events
debug ip ospf adj

EIGRP

1.Cấu hình cơ bản.

Router(config)#router eigrp autonomous number
Router(config-router)#network network number
Router(config-router)#eigpr log-neighbor-changes (Không có cũng được)
Router(config-router)#no auto-summary

2.Thay đổi băng thông và tự tổng hợp tuyến trong interface

Router(config-if)#bandwidth kilobits
Router(config-if)#ip summary-address protocol AS network number subnets mask

3.Cân bằng tải trong EIGRP

Router(config-router)#variance number

4.Quảng bá default route

Cách 1:
Router(config)#ip route 0.0.0.0 0.0.0.0 [interface/nexthop]
Router(config)#redistribute static

Cách 2:
Router(config)#ip default-network network number

Cách 3:
Router(config-if)#ip summary-network eigrp AS number 0.0.0.0 0.0.0.0

5.Quảng bá các tuyến khác trong EIGRP (không phải là default)

Router(config-router)#redistribute protocol process ID metrics k1 k2 k3 k4 k5
Ex: Router(config-router)#redistribute ospf metrics 100 100 100 100 100

6.Chia sẻ traffic trong EIGRP

Router(config-router)#traffic share {balanced/min}

7.Các lệnh kiểm tra cấu hình EIGRP

<!--[if !supLists]-->- <!--[endif]-->show ip eigrp neighbor
<!--[if !supLists]-->- <!--[endif]-->show ip eigrp interface
<!--[if !supLists]-->- <!--[endif]-->show ip eigrp topology
<!--[if !supLists]-->- <!--[endif]-->show ip eigrp traffic
<!--[if !supLists]-->- <!--[endif]-->debug eigrp fsm
<!--[if !supLists]-->- <!--[endif]-->debug eigrp packet
avatar
telecom1988
Admin

Posts : 317
Join date : 2009-04-08
Age : 30
Location : 144 Xuan Thuy - Cau Giay - Ha Noi

View user profile http://banks.forum.st

Back to top Go down

Re: Cấu hình OSPF và EIGRP

Post  doanbaotrung on Tue Apr 05, 2011 8:09 pm


Cho em hỏi là trong hình trên nếu liên kết giữa C và D bị đứt thì cập nhật sẽ được ai gửi và gửi đến những ai?
Khi có sự thay đổi thì gói update sẽ được gửi cho tất cả router hay chỉ gửi cho neighbor của nó thôi?

doanbaotrung

Posts : 2
Join date : 2011-04-05

View user profile

Back to top Go down

Re: Cấu hình OSPF và EIGRP

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum