Lab 6-1: REDISTRIBUTION GIỮA RIP VÀ OSPF

Go down

Lab 6-1: REDISTRIBUTION GIỮA RIP VÀ OSPF

Post  telecom1988 on Sun May 10, 2009 9:21 pm

Lab 6-1: REDISTRIBUTION GIỮA RIP VÀ OSPF



Mô tả



Bài thực hành này mô tả cách thức redistribution giữa một giao thức định tuyến link state (OSPF) và giao thức định tuyến distance vector (RIP). Mạng B và mạng A chạy hai giao thức định tuyến khác nhau. Mạng A chạy OSPF trên RouterA, RouterB, và RouterC và mạng B chạy RIP trên RouterD. Tất cả các router kết nối vớI nhau dùng cổng serial. Cổng Serial và Ethernet của RouterA thuộc OSPF vùng 1 cùng với cổng S0 của RouterB. Cổng S0 của RouterC và S1 của RouterB thuộc vùng 0. RouterD chạy RIP trên tất cả các mạng, RouterC thực hiện phân phối giữa OSPF và RIP.
Cấu hình ban đầu

RouterA

!

hostname RouterA

!

interface Loopback0

ip address 152.1.11.1 255.255.255.240

!

interface Ethernet0

ip address 152.1.10.1 255.255.255.0

no keepalive

!

interface Serial0

ip address 152.1.1.1 255.255.255.252

!

router ospf 64

network 152.1.1.0 0.0.0.3 area 1

network 152.1.10.1 0.0.0.255 area 1

!

no ip classless

!

line con 0

line vty 0 4

!

end

RouterB

!

hostname RouterB

!

interface Serial0

ip address 152.1.1.2 255.255.255.252

no fair-queue

clockrate 64000

!

interface Serial1

ip address 152.1.1.5 255.255.255.252

clockrate 64000

!

!

router ospf 64

network 152.1.1.0 0.0.0.3 area 1

network 152.1.1.4 0.0.0.3 area 0

!

line con 0

line aux 0

transport input all

line vty 0 4

login

!

end

RouterC

!

hostname RouterC

!

interface Serial0

ip address 152.1.1.6 255.255.255.252

!

interface Serial1

ip address 152.1.2.1 255.255.255.0

clockrate 500000

!

router ospf 64

redistribute rip

network 152.1.1.4 0.0.0.3 area 0

default-metric 64 ß gán giá trị mặc định cho các route từ ngoài vào

!

router rip

redistribute ospf 64 ß đưa những OSPF routes vào RIP

passive-interface Serial0

network 152.1.0.0

default-metric 2 ¬ đặt metric 2 cho tất cả các route được phân phối vào RIP.

!

no ip classless

!

line con 0

line 1 16

line aux 0

line vty 0 4

login

!

end

RouterD

!

hostname RouterD

!

interface Loopback0

ip address 152.1.3.1 255.255.255.0

!

interface Serial0

ip address 152.1.2.2 255.255.255.0

!

!

router rip

network 152.1.0.0

!

no ip classless

!

line con 0

line aux 0

line vty 0 4

login

!

end
Kiểm tra



Xem bảng định tuyến IP trên RouterC. Chú ý rằng RouterC đã học được mạng 152.1.3.0 (cổng loopback của RouterD) thông qua RIP. Nó cũng học được mạng 152.1.10.0/24 và mạng 152.1.1.0/30 thông qua OSPF. Các route học được là dạng inter-area, bởi vì chúng xuất phát từ vùng 1 OSPF. RouterC không học được mạng 152.1.11.0/28 (cổng loopback của RouterA) bởi vì mạng này không được cấu hình chạy OSPF, nó không được quảng cáo.

RouterC#show ip route

...

Gateway of last resort is not set

152.1.0.0/16 is variably subnetted, 5 subnets, 2 masks

O IA 152.1.10.0/24 [110/138] via 152.1.1.5, 00:03:01, Serial0

O IA 152.1.1.0/30 [110/128] via 152.1.1.5, 00:03:01, Serial0

R 152.1.3.0/24 [120/1] via 152.1.2.2, 00:00:15, Serial1

C 152.1.2.0/24 is directly connected, Serial1

C 152.1.1.4/30 is directly connected, Serial0

Để khắc phục vấn đề này, đơn giản là chạy OSPF trên mạng, sau đó nó sẽ được quảng cáo. Một cách khác là phân phối các mạng nối trưc tiếp (connected subnet) trên RouterA vào OSPF. Thêm các lệnh sau vào tiến trình OSPF trên RouterA.

RouterA#config ter

RouterA(config)#router ospf 64

RouterA(config-router)#redistribute connected subnets

Bây giờ xem lại bảng định tuyến trên RouterC. Lúc này RouterC đã thấy route 152.1.11.0/28 tuy nhiên route này là dạng external vì nó được phân phối vào.

RouterC#show ip route

...

Gateway of last resort is not set

152.1.0.0/16 is variably subnetted, 6 subnets, 3 masks

O E2 152.1.11.0/28 [110/20] via 152.1.1.5, 00:02:06, Serial0

O IA 152.1.10.0/24 [110/138] via 152.1.1.5, 00:02:06, Serial0

O IA 152.1.1.0/30 [110/128] via 152.1.1.5, 00:02:06, Serial0

R 152.1.3.0/24 [120/1] via 152.1.2.2, 00:00:06, Serial1

C 152.1.2.0/24 is directly connected, Serial1

C 152.1.1.4/30 is directly connected, Serial0



Bây giờ xem bảng định tuyến trên RouterA, RouterA không nhận được route tới mạng 152.1.3.0/24

RouterA#show ip route

...

Gateway of last resort is not set

152.1.0.0/16 is variably subnetted, 4 subnets, 3 masks

C 152.1.11.0/28 is directly connected, Loopback0

C 152.1.10.0/24 is directly connected, Ethernet0

C 152.1.1.0/30 is directly connected, Serial0

O IA 152.1.1.4/30 [110/128] via 152.1.1.2, 00:02:29, Serial0



Các route học từ RIP không hoàn toàn được phân phối vào OSPF bởi vì cấu hình trên RouterC. Chỉ những route có 16-bit mask (lớp B) được phân phối vào OSPF. Các mạng trên RouterD đã được chia mạng con với 24-bit mask. Để các mạng con có thể phân phối được phải xác định trong cấu hình, thêm câu lệnh sau trong tiến trình OSPF trên RouterC.

RouterC#config t

RouterC (config)#router ospf 64

RouterC (config-router)#redistribute rip subnets

Xem lại bảng định tuyến trên RouterA. Lúc này, RouterA đã có các route tới mạng 152.1.2.0 và 152.1.3.0, chú ý rằng các router này là external (O E2) do chúng được học từ vùng khác.

RouterA#show ip route

...

Gateway of last resort is not set

152.1.0.0/16 is variably subnetted, 6 subnets, 3 masks

C 152.1.11.0/28 is directly connected, Loopback0

C 152.1.10.0/24 is directly connected, Ethernet0

C 152.1.1.0/30 is directly connected, Serial0

O E2 152.1.3.0/24 [110/64] via 152.1.1.2, 00:00:38, Serial0

O E2 152.1.2.0/24 [110/64] via 152.1.1.2, 00:00:38, Serial0

O IA 152.1.1.4/30 [110/128] via 152.1.1.2, 00:04:05, Serial0

Xem bảng định tuyến trên RouterD. RouterD chỉ học được một mạng 152.1.10.0/24 bởi vì tất cả các mạng khác đã chia subnet, chỉ có mạng con với 24-bit mask mới được thêm vào bảng định tuyến; chú ý rằng RIP là giao thức định tuyến classful và không mang thông tin subnet.

RouterD#show ip route

...

Gateway of last resort is not set



152.1.0.0/24 is subnetted, 3 subnets

R 152.1.10.0 [120/2] via 152.1.2.1, 00:00:11, Serial0

C 152.1.3.0 is directly connected, Loopback0

C 152.1.2.0 is directly connected, Serial0

Để các route có thể phân phối vào RIP, có thể sử dụng định tuyến tĩnh tới hai mạng dùng mask 24-bit và phân phối các route này vào trong RIP, hay có thể summarize các route trong OSPF.

Xem xét giải pháp thứ nhất. Tạo hai route tĩnh trên RouterC dùng 24-bit mask.

RouterC#conf t

RouterC(config)#ip route 152.1.11.0 255.255.255.0 s0

RouterC(config)#ip route 152.1.1.0 255.255.255.0 s0

Phân phối các route này vào RIP trên RouterC

RouterC(config)#router rip

RouterC(config-router)#redistribute static

Xem bảng định tuyến IP trên RouterD, lúc này RouterD đã có các route của cả hai mạng.

RouterD#sh ip route

...

Gateway of last resort is not set

152.1.0.0/24 is subnetted, 5 subnets

R 152.1.11.0 [120/1] via 152.1.2.1, 00:00:21, Serial0

R 152.1.10.0 [120/2] via 152.1.2.1, 00:00:21, Serial0

R 152.1.1.0 [120/1] via 152.1.2.1, 00:00:21, Serial0

C 152.1.3.0 is directly connected, Loopback0

C 152.1.2.0 is directly connected, Serial0

Xem xét giải pháp thứ hai là thực hiện thu gọn các router dùng 24-bit mask trong OSPF. Trước tiên, bỏ các tuyến đường tĩnh và redistribute static trên RouterC.

RouterC#conf t

RouterC(config)#no ip route 152.1.11.0 255.255.255.0 s0

RouterC(config)#no ip route 152.1.1.0 255.255.255.0 s0

RouterC(config)#router rip

RouterC(config-router)#no redistribute static

Để thực hiện thu gọn, phải dùng các lệnh area range và summary-address. Lệnh area range được dùng để thực hiện summay các route từ các vùng OSPF nonbackbone vào vùng 0 và lệnh summay-address được dùng để tóm tắt các external route trên một ASBR. Trong bài thực hành này ta có cả hai loại: mạng 152.1.11.0/28 là external route vì nó được phân phối vào OSPF và mạng 152.1.1.0/30 thuộc vùng 1 là vùng loại nonbackbone.

¤ Lệnh summary-address chỉ tóm tắt các route từ các giao thức định tuyến khác được phân phối vào OSPF. Lệnh area range được dùng để tóm tắt các route giữa các vùng OSPF; lệnh này được dùng trên các router ABR (area border router) và lệnh summay-address được dùng trên các router ASBR (autonomous system border router)

Thêm lệnh summay-address trong tiến trình OSPF trên RouterA. Thực hiện lệnh này để tóm tắt mạng 152.1.11.0/28 thành mạng 152.1.11.0/24 có thể truyền tới RouterD.

RouterA#conf t

RouterA(config)#router ospf 64

RouterA(config-router)#summay-address 152.1.11.0 255.255.255.0

Xem bảng định tuyến trên RouterD, lúc này RouterD đã nhận được route tới mạng 152.1.11.0/24

RouterD#sh ip ro

Gateway of last resort is not set



152.1.0.0/24 is subnetted, 4 subnets

R 152.1.11.0 [120/2] via 152.1.2.1, 00:00:02, Serial0

R 152.1.10.0 [120/2] via 152.1.2.1, 00:00:02, Serial0

C 152.1.3.0 is directly connected, Loopback0

C 152.1.2.0 is directly connected, Serial0

Thêm lệnh area range trong tiến trình OSPF trên RouterB. Lệnh này dùng để tóm tắt mạng 152.1.1.0/30 thành mạng 152.1.1.0/24 có thể truyền cho RouterD

RouterB#conf t

RouterB(config)#router ospf 64

RouterB(config-router)#area 1 range 152.1.1.0 255.255.255.0

RouterB#clear ip ospf process

Reset ALL OSPF processes? [no]: yes

Xem bảng định tuyến trên RouterD, đã xuất hiện mạng 152.1.1.0/24.

RouterD#show ip route

...



152.1.0.0/24 is subnetted, 5 subnets

R 152.1.11.0 [120/2] via 152.1.2.1, 00:00:18, Serial0

R 152.1.10.0 [120/2] via 152.1.2.1, 00:00:18, Serial0

R 152.1.1.0 [120/2] via 152.1.2.1, 00:00:18, Serial0

C 152.1.3.0 is directly connected, Loopback0

C 152.1.2.0 is directly connected, Serial0

Giá trị metric và split horizon sẽ tránh việc routes được phân phối loop. Nhưng tốt hơn là tạo distribute list để router không quảng cáo sai các route. Để mô tả cách này vô hiệu hóa split horizon trên cổng Serial 1 của RouterC

RouterC#conf t

RouterC(config)#interface s1

RouterC(config-if)#no ip split-horizon

Xem các gói RIP cập nhật từ RouterC bằng lệnh debug ip rip trên RouterD. Từ thông báo trên màn hình chú ý rằng RouterC bây giờ nhận được mạng 152.1.3.0 là mạng nối trực tiếp với RouterD. Mặc dù RouterD không đưa router này vào bảng định tuyến, nhưng tốt hơn là phải lọc route này dùng distribute list trên RouterC.

RouterD#debug ip rip

RouterD#

01:06:15: RIP: received v1 update from 152.1.2.1 on Serial0

01:06:15: 152.1.11.0 in 2 hops

01:06:15: 152.1.10.0 in 2 hops

01:06:15: 152.1.1.0 in 2 hops

01:06:15: 152.1.3.0 in 2 hops

01:06:15: 152.1.2.0 in 1 hops

Tạo distribute list trên RouterC để cho phép các mạng 152.1.11.0, 152.1.1.0 và 152.1.10.0 được quảng cáo bằng RIP. Có hai bước để thực hiện. Trước tiên tạo access-list để permit hay deny một mạng; sau đó áp dụng access-list vào các thông tin cập nhật bằng cách dùng distribute-list.



Tạo access-list trên RouterC cho phép các mạng 152.1.11.0, 152.1.1.0 và 152.1.10.0

RouterC#conf t

RouterC(config)#access-list 1 permit 152.1.1.0 0.0.0.255

RouterC(config)#access-list 1 permit 152.1.11.0 0.0.0.255

RouterC(config)#access-list 1 permit 152.1.10.0 0.0.0.255



Áp dụng access-list cho các routing thông tin cập nhật định tuyến



RouterC(config)#router rip

RouterC(config-router)#distribute-list 1 out

Xem các gói RIP thông tin cập nhật định tuyến từ RouterC bằng lệnh debug ip rip trên RouterD. Lúc này RouterC chỉ quảng cáo 3 mạng nói trên.

01:15:16: RIP: received v1 update from 152.1.2.1 on Serial0

01:15:16: 152.1.11.0 in 2 hops

01:15:16: 152.1.10.0 in 2 hops

01:15:16: 152.1.1.0 in 2 hops

01:15:43: RIP: sending v1 update to 255.255.255.255 via Loopback0 (152.1.3.1)

01:15:43: RIP: build update entries

01:15:43: subnet 152.1.1.0 metric 3

01:15:43: subnet 152.1.2.0 metric 1

01:15:43: subnet 152.1.10.0 metric 3

01:15:43: subnet 152.1.11.0 metric 3

01:15:43: RIP: sending v1 update to 255.255.255.255 via Serial0 (152.1.2.2)

01:15:43: RIP: build update entries

01:15:43: subnet 152.1.3.0 metric 1
avatar
telecom1988
Admin

Posts : 317
Join date : 2009-04-08
Age : 30
Location : 144 Xuan Thuy - Cau Giay - Ha Noi

View user profile http://banks.forum.st

Back to top Go down

Câu lênh cấu hình định tuyến cho các giao thức

Post  telecom1988 on Sun May 10, 2009 9:26 pm

Đinh tuyến cơ bản là một phần hết sức quan trọng trong CCNA course. Bài viết này mình xin giơi thiệu với các bạn trình tự làm một bài LAB hoan chỉnh cho phần đinh tuyến cho Router...

Trình tự làm một bài LAB
Bước 1
Vẽ sơ đồ
Chia subnet
Nối cáp ( kiểm tra lớp 1)

Bước 2 Router – cấu hình cơ bản.
Router#config terminal

hostname(config)#hostname A

password(config)#enable password cisco
(config)#enable secret cisco (1 trong 2 loại)

Các đường line(config)#line vty 0 4
(config-line)#password cisco
(config-line)#login
(config)#line console 0
(config-line)#password cisco
(config-line)#logging synchronous
(config-line)#login
(config)#line aux 0
(config-line)#password cisco
(config-line)#login

Banner(config)#banner motd
Enter TEXT message. End with the character '#'.

DNS(config)#no ip domain-lookup

Tạo IP host table(config)#ip host name address
R1(config)#ip host R1 192.169.1.1
R1(config)#ip host R2 192.169.2.2
R1(config)#ip host R3 192.169.3.3

Interface
Ethernet (config)#interface f0/0
(config-if)#ip address 192.168.1.1 255.255.255.0
(config-if)#description (connected ....)
(config-if)#no shut
Loop back(config)#interface Loopback 0
(config-if)#ip address 192.168.1.1 255.255.255.0 ( đối với OSPF khi cần dùng /32)
Serial (config)#interface s0/0
(config-if)#ip address 192.168.1.1 255.255.255.0
(config-if)#description (connected ....)
(config-if)#clock rate 64000
(config-if)#no shut
Các lệnh khác

Router#show ?
Router#show interfaces
Router#show interface serial 0
Router#show ip interface brief
Router#show controllers serial 0
Router#show hosts
Router#show users
Router#show flash
Router#show version
Router#show protocols
Router#show startup-config
Router#show running-config
Show


Bước 3. Định tuyến
Định tuyến tĩnh
(config)#ip route 172.16.20.0 255.255.255.0 next-hop or interface
Defaul route
(config)#ip route 0.0.0.0 0.0.0.0 next-hop or interface
Chú ý định tuyến tĩnh AD = 1

RIP

(config)#router rip ( mặc định gửi ver 1 nhận 1,2
(config-router)#network w.x.y.z
(config-router)#no ip split-horizon
(config-router)#passive-interface s0/0

RIP version 2(config-router)#version 2
(config-if)#ip rip send version 1 | 2
(config-if)#ip rip receive version 1 | 2
(config-router)#no auto-summary
Defaul route
(config)#ip route 0.0.0.0 0.0.0.0 next-hop
(config)#router rip
(config-router)#default-information originate

Hoặc
(config)#ip route 0.0.0.0 0.0.0.0 next-hop
(config)#router rip
(config-router)#redistribuite static

Hoặc
(config)#ip route 0.0.0.0 0.0.0.0 interface
(config)#router rip
(config-router)#redistribuite connected

Redistribuiting
(config)#router rip
(config-router)#redistribute ospf 1 metric 1
(config-router)#redistribute eigrp 100 metric 1

Authentication
Plain-text
(config)#K.@.y chain cisco
(config-keychain)#K.@.y 1
(config-keychain-K.@.y)#K.@.y-string class
(config-keychain-K.@.y)#exit
(config-keychain)#exit
khi đặt authentication thì phải đặt trên các subinterface nếu có
(config)#interface FastEthernet0/0.1
(config-subif)#ip rip authentication K.@.y-chain cisco
(config-subif)#ip rip authentication mode text
MD5

(config)#K.@.y chain cisco
(config-keychain)#K.@.y 1
(config-keychain-K.@.y)#K.@.y-string class
(config-keychain-K.@.y)#exit
(config-keychain)#exit

(config)#interface FastEthernet0/0.1
(config-subif)#ip rip authentication K.@.y-chain cisco
(config-subif)#ip rip authentication mode md5


Troubleshooting Router#debug ip rip
Router#show ip rip database


IGRP- EIGRP
(config)#router eigrp 55
(config-router)#network 172.25.0.0
(config-router)#network 192.168.20.0

Biến varian(config-router)#variance x


Redistribuite (config-router)#redistribute rip metric ?
<1-4294967295> Bandwidth metric in Kbits per second

(config-router)#redistribute rip metric 2000 ?
<0-4294967295> IGRP delay metric, in 10 microsecond units

(config-router)#redistribute rip metric 2000 200 ?
<0-255> IGRP reliability metric where 255 is 100% reliable

(config-router)#redistribute rip metric 2000 200 255 ?
<1-255> IGRP Effective bandwidth metric (Loading) where 255 is 100% loaded

(config-router)#redistribute rip metric 2000 200 255 1 ?
<1-4294967295> IGRP MTU of the path

(config-router)#redistribute rip metric 2000 200 255 1 1500
Default route
Cách 1
(config)#ip route 0.0.0.0 0.0.0.0 172.25.1.1
(config)#router eigrp 55
(config-router)#redistribute static
Cách 2 (config)#ip route 0.0.0.0 .0.0.0 131.108.3.4
(config)#ip default-network 131.108.3.0

Cách 3
(config)#router eigrp 100
(config-router)#no auto-summary
(config)#int fa 0/0
(config-if)ip summary-address eigrp 100 0. 0.0.0 0.0.0.0
Authentication
Router1(config)#K.@.y chain cisco
Router1(config-keychain)#K.@.y 1
Router1(config-keychain-K.@.y)#K.@.y-string class
Router1(config-keychain-K.@.y)#exit
Router1(config-keychain)#exit

Router1(config)#interface Serial0/1
Router1(config-if)#ip authentication mode eigrp 55 md5
Router1(config-if)#ip authentication K.@.y-chain eigrp 55 cisco
OSPF
(config)#router ospf 1
(config-router)#network 192.168.1.0 0.0.0.255 area 0

Default route(config)#ip route 0.0.0.0 0.0.0.0 next-hop
(config)#router ospf 1
(config-router)#default-information originate


authentication

Clear text
Router(config)#router ospf 1
Router(config-router)#area 0 authentication
Router(config-router)#exit
Router(config)#int fa 0/0
Router(config-if)#ip ospf authentication-K.@.y cisco


MD5
Router(config)#router ospf 1
Router(config-router)#area 0 authentication message-digest
Router(config-router)#exit
Router(config)#int fa 0/0
Router(config-if)#ip ospf message-digest-K.@.y 1 md5 cisco
avatar
telecom1988
Admin

Posts : 317
Join date : 2009-04-08
Age : 30
Location : 144 Xuan Thuy - Cau Giay - Ha Noi

View user profile http://banks.forum.st

Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum